読者です 読者をやめる 読者になる 読者になる

rubygems_check_replacement_vulnerabilityのDocker Image作った

id:sue445 さんが改ざんチェックgemを作ってくれたとのことで早速ためそう!

sue445.hatenablog.com

と思ったらMBPリストアしたばっかりでrbenv入ってなくて環境が整ってなかったのでrbenv突っ込んでrubyのビルドして・・・

やってられっかーーーーー!となって作りました。よしなにお使いください。

使い方

以下をbashrc or zshrcに突っ込んで source したらあとは普通に こちら の記事を参考にお使いください。

rubygems_check_replacement_vulnerability () {
  docker run --rm cynipe/rubygems_check_replacement_vulnerability $@
}

もちろん docker run --rm cynipe/rubygems_check_replacement_vulnerability vulnerable_gems --username=<USERNAME> とかしてもOK。

わーい、だいじょぶ!

rubygems_check_replacement_vulnerability verify_gem --name=jenkins-capistrano --repo-url=https://github.com/cynipe/jenkins-capistrano
Unpacked gem: '/tmp/gem-20160415-1-19bjy7s/jenkins-capistrano-0.1.0'
[Info] jenkins-capistrano 0.1.0 is safe!
Unpacked gem: '/tmp/gem-20160415-1-1ujzn0g/jenkins-capistrano-0.1.1'
[Info] jenkins-capistrano 0.1.1 is safe!
Unpacked gem: '/tmp/gem-20160415-1-136bp3f/jenkins-capistrano-0.1.2'
[Info] jenkins-capistrano 0.1.2 is safe!